Really need to work on this

Moderators: Cycona2704, MVP, Moderator, Dev Team

no avatar

Bearded_One

Senior Member

Windows PC
Posts

149

Really need to work on this

Tue Feb 23, 2021 5:09 pm
This season has been the worst for wrecking because you took a jump. It seems like a game flaw that you wreck on landing. This is happening every day now.
no avatar

Hiwrx

Senior Member

Apple (iOS)
Posts

286

Re: Really need to work on this

Wed Feb 24, 2021 9:07 am
Yup seeing this more with me as well. And this is happening with cars that have good handling stats. Plus, it’s also happening when my car is falling pretty much horizontal, with all four wheels pointing down, ready to absorb contact
Hiwrx's MP Mantra - "Multiplayer? What's that?"

GL Customer Care Mantra - "Submit a customer care ticket"  "Send me a screenshot"
User avatar

Violo

Veteran

Apple (iOS)
Posts

612

Re: Really need to work on this

Thu Feb 25, 2021 2:42 am
Aside from some slight suspicion with the Lotus Elise Sprint 220, I have not encountered this issue yet. 😎
User avatar

Zyzigy

Senior Member

Windows PC
Posts

221

Location

Australia

Re: Really need to work on this

Thu Feb 25, 2021 10:37 am
Maybe, and I hate to say it, it could be server lag.

Yesterday, Himalayas, clearly placed first. Even the replay showed I placed first. But, according to the leader-board, I placed third.
The next few races I got a whole lot of 'you have a bad connection' thrown up at me.

Maybe you're seeing that you've leveled out ready to land perfectly, but the server sees you half rolled over or something.

It might sound crazy, but lets face it, we're talking about Asphalt 9 here.