no avatar


Junior Member



Download eror 0x80070490

Mon Oct 03, 2016 10:55 pm
Download eror 0x80070490
Mo October 3, 2016 10:55 pm

Played that game on laptop, that device is now "dead", and I try to instal the game on my desctop (both have the same ID), downloaded and it do not want komplet,then says that something go wrong, error 0x80070490 .....
 what can I do now ... both devices have win 10, with recent updates, everything else is functioning normally ...

Tried all toturials to resolve the problem (win shop error, reset,automatic update...)

please help ...

Spielte dass spiel am laptop, dass gereat ist jetzt kaput, und wolte das Spiel am desctop instalieren (hat selbes ID) und es wird komplet heruntergeladen u dann sagt dass ding das ein feller gefunden ist, 0x80070490.....was kann ich jetzt machen...

An beiden gereten sind Win 10, mit letzten updates, alles andere funktioniert normal...bitte um hilfe...

(sorry fuer meine gramatik, bin aus Kroatien und auser uebung)

User avatar

Kiwi Claire

Grand Master

Windows PC


Re: Download eror 0x80070490

Thu Oct 13, 2016 8:10 am
I had the same error... Happened for both Sniper Fury and Asphalt 8: Airborne. Both Gameloft games. No other apps seemed to have problems...
tried a lot of posted possible solutions.
Finally found this MS forum posting. most of the posts are solutions I had already tried... except for 2nd to last reply.

From that reply
I ran this code in the terminal prior to my solution, not knowing if that had anything to do with my upcoming solution:
Dism.exe /online /cleanup-image /scanhealth
Dism.exe /online /cleanup-image /restorehealth
sfc /scannow

Anyway, this is what solved the issue for me:
1: Use your current Admin account (mine was local) to create a new local account with Admin privileges.
2: Log out of your current Account and into the new account with Admin privileges. You will se Win10 setting up the account for the first time. As you get logged in, wait a minute or two, as this was the point where I got the message that some apps have gotten their settings reset.
3: After I got the message I went to the store using the new Account and downloaded a free software just to verify that it was Win Store that was reset, and indeed it was. I got no Issues.
4: Logged out and back into my old Admin account to see if it was solved and i was.

That worked for me.