User avatar

Hex0mega

Junior Member

Google Play (Android)
Posts

10

I am getting SO sick of all the bugs at this point. I am frustrated beyond belief! Here is a list of some if the things I have come across in merely a week after returning to the game. Not sure whether I should have even bothered...

1: Can't make purchases.
I had to uninstall the game and reinstall it to get anything. I thought that fixed it because I got the $1.99 subscription for unlimited energy after that. The next day, I went to get some credits for something, and I was once again unable to make purchases. I get the transaction processing loading screen and once it dissapears, my Google Play payment confirmation just never comes up. After that, pressing on anything in the market just does nothing.

2: Ad problems.
Now, this has been a consistent problem since the game came out. The streaming service they use for ads on this game is about hot garbage. You go to watch a video for your daily rewards and you get "Ad playback failed. Please try again later!" about 75% of the time and then you have to wait like an hour or more before you try again because it can't find any ads. Its not because I've used up all my views, as it can happen from the very first time I go to watch an ad for the new day. Ads will also occasionally glitch out and then sometimes I won't get the draw. This happens with the weapons chest especially. 

3: Controller detection.
Now, before I uninstalled the game and reinstalled it to try and troubleshoot the purchasing error, it was detecting my controller without any issues. Since I have reinstalled it, I now have to re-connect my controller to my bluetooth on my phone while the game is open. If I close the game for whatever reason or the game times out because I had another window open, I get to do that again. Its very 

4: Missing rewards.
I drew 2 camos from the combat egg event going on right now. One of the two I actually got. The other... isn't even on the camo list. It was a gun camo I believe, and I actually checked both the armor and the gun camos and I don't even see the pattern I unlocked. Not even as a locked option... I don't remember what it was called but it looks like kind of a bronze techy pattern.

5: Shot accuracy for mission stars.
You need to be at least 30% more accurate than the requirement actually says. For instance, the "Getaway" mission, which is the last of the 6 missions from "Escape" says you need 60% accuracy. I have tried countless times. I have sank every bullet into an enemy save for about 1 or 2 shots, and they're mostly headshots. I killed a few and then leave a lot of the enemies to the companion you get in the mission to save me from an opportunity to ruin my score. If I killed about 12-15 or more guys and miss 2 or 3 shots, and I have less than a 60% shot accuracy, then Gameloft's idea of 60% and mine must be 2 different things. I'd say you need 100% for that mission...

6: The tutorial mission.
This may not be a bug, but it needs addressed. Its ridiculous to have to do the first like 3 or 4 minute mission every time you reinstall the game. The option to load your profile should be presented before the tutorial, not after. That gets really redundant and if I am having issues like say the purchasing problem I am experiencing right now, I am reluctant to try and troubleshoot via reinstallation because I don't wanna do the first godforsaken mission for the 10th time. I take breaks from games and come back, and the last thing I wanna do is be welcomed with the lengthy tutorial mission each time.

These are just a few issues and at the rate this is going, I know I'll find more. The game has been out for several years and some of these issues are ones that I have experienced since the release of the game, and I have played the game on several different devices since then, so it can't be blamed on my phone model. This tells me that there is a disheartening lack of enthusiasm to try and smooth put the edges of this game and make sure there aren't any bugs. Its very annoying...